Android 14 будет блокировать установку несвежих приложений

Android 14, которая должна выйти в следующем году, будет блокировать установку приложений, нацеленных на более старые версии Android. Блокировка касается и механизма загрузки программ из посторонних источников.

Не всегда новая версия программы лучше старой, однако пользователей часто заставляют переходить на новые версии приложений. Смартфоны Android также начнут заставлять пользователей использовать самые свежие версии приложений. Установка более старых версий будет блокироваться.

Эксперты издания 9to5Google заметили частную настройку кода в Android 14, указывающую на более строгие требования к API для установки программы.

В этой настройке говорится: «Если включено принудительное выполнение минимальной установленной версии SDK, заблокируйте установку приложений с более низкой целевой версией SDK, чем требуется. Это помогает повысить безопасность и конфиденциальность, поскольку вредоносное программное обеспечение может нацелиться на более старые версии SDK во избежание применения нового поведения API».

Другими словами, Android 14, которая должна выйти в следующем году, будет блокировать установку приложений, нацеленных на более старые версии Android. Блокировка касается и механизма загрузки программ из посторонних источников.

Сообщается, что сначала Android 14 будет блокировать только самые старые уровни API, но в долгосрочной перспективе планируется повысить порог до Android 6.

Такие изменения не должны стать полной неожиданностью. Google уже требует от разработчиков обновлять свои приложения до свежих версий Android, если они хотят продолжать публиковать обновления в Play Store. Однако это требование не распространяется, если пользователь устанавливает приложение самостоятельно из постороннего источника.

НАПИСАТИ ВІДПОВІДЬ

Коментуйте, будь-ласка!
Будь ласка введіть ваше ім'я